ヘルプの森~Excel・Access・Office全般ヘルプデスクサイト

No.001

アイコン 欠番が出たオートナンバー型フィールドの番号をふり直すには

Access2003/2007/2010/2013

オートナンバー型のフィールドがあるテーブルでレコードが削除されると、オートナンバーに欠番が生じます。
欠番の番号を入力しようとしても、オートナンバー型では常に新しい最大の連番がふられるため、欠番を埋めることはできません。

もちろん、Accessの管理において、欠番はまったく問題ありません。番号をふりなおしたいというのは、人間の気持ちによるものですね。

例えば、このようなオートナンバーに欠番が生じたテーブルがあります。

欠番テーブル

今回連番を1からふりなおす方法ですが、欠番の後のレコードは繰り上がりの番号となります。

複数の方法をご紹介します。どの方法にせよ、同じデザイン ビュー設定の新しいテーブルを作成します。手順は次のとおりです。

  1. オートナンバーを振りなおしたいテーブルを選択し、[ホーム]タブや右クリック、ショートカット キーを利用してコピーします。
  2. そのまま同じところで[貼り付け]します。
  3. 表示された[テーブルの貼り付け]ダイアログ ボックスで、[テーブル名]を任意に指定、[貼り付けの設定]で[テーブル構造のみ]オプションを選択し、[OK]をクリックします。
    貼り付けの設定

これで、同じデザイン ビューの新しいテーブルができあがりました。

このテーブルに、現在の欠番が出ているレコードを追加すればよいのです。
追加するときのポイントは「オートナンバーのフィールド以外を追加する」ことです。

追加する方法は次の3通りでしょうか。簡単な順にご案内いたします。

<新規テーブルにコピー>

この方法は完全手動な方法です。

  1. 最初の手順で、同じデザイン ビュー設定の新しいテーブルを作成しておきます。
  2. 欠番が出ているテーブルの、オートナンバー フィールド以外のレコードを列選択し、
    コピーします。
    レコードコピー
  3. 新しいテーブルの、オートナンバー以外のフィールドを列選択して、貼り付けます。
  4. レコードを貼り付けるかどうかのメッセージが表示されますので、[はい]をクリックします。
    テーブルの貼り付け

<Excelからインポート>

この方法は、Excelのデータをインポートするときの特徴を利用した方法です。

  1. 最初の手順で、同じデザイン ビュー設定の新しいテーブルを作成しておきます。
  2. 欠番が出ているテーブルの、オートナンバー フィールド以外のレコードを列選択します。
  3. 2のデータをコピーし、新規作成したExcelのセルA1に貼り付け、保存します。
    または、1のデータ範囲をExcelにエクスポートします。
    エクスポートは、[外部データ]タブ-[エクスポート]グループ-[Excel]ボタンから、保存先とExcelファイル名を指定し、[書式設定トレイアウトを保持したままデータをエクスポートする]と[選択したレコードのみをエクスポートする]チェック ボックスをオンにして[OK]をクリックします。
    これで、インポート元のExcelができあがりました。
    インポート元Excel
  4. 保存したExcelを、先に用意した新しいテーブルにインポートします。
    インポートは、[外部データ]タブ-[インポートとリンク]グループ-[Excel]ボタンから、保存したExcelを指定し、[レコードのコピーを次ぐのテーブルに追加する]オプションを選んで実行します。

かえって面倒な方法ですけれども、Excelのデータをオートナンバー型を持つテーブルにインポートすると連番が作成されることを知っていると、別の機会にうまく利用できるかもしれませんよ。

<追加クエリを利用>

この方法は全自動が可能な方法です。

  1. 最初の手順で、同じデザイン ビュー設定の新しいテーブルを作成しておきます。
  2. クエリをデザイン ビューで新規作成し、欠番テーブルを追加、オートナンバー型以外のフィールドを追加します。
    クエリデザインビュー
  3. [クエリ ツール]-[デザイン]タブ-[クエリの種類]グループ-[追加]ボタンをクリックします。
    これでクエリは、追加クエリとなります。
  4. 表示される[追加]ダイアログ ボックスで、1で用意したテーブルを指定し[OK]をクリックします。
    追加クエリ
  5. [クエリ ツール]-[デザイン]タブ-[結果]グループ-[実行]ボタンをクリックして
    追加クエリを実行します。
  6. 使用した追加クエリは必要であれば保存します。

新しいテーブルを用意し、追加クエリを実行すればよいだけです。
連番振り直しがよくある場合は、この方法がおすすめです。

Access2003でのコマンドの場所は、次のとおりです。
インポートやエクスポートは、[ファイル]メニュー-[外部データの取り込み]-[インポート]、また[ファイル]メニュー-[エクスポート]です。
追加クエリの作成は、クエリをデザイン ビューにして、[クエリ]メニュー-[追加]をクリックします。

関連ヘルプ

テーブルのデータの一部分の文字列を別の文字列に置き換える
テーブルデータの先頭にあるシングル クォーテーション(')を取りたい
オートナンバー型フィールドの書式を変更する
Accessの日付、時刻の書式(表示形式)について
郵便番号⇔住所の自動入力機能の設定(住所入力支援プロパティ)
市区町村の合併で郵便番号や住所が変更された場合の住所入力支援の更新について
オートナンバーを任意の番号からからふられるようにする
テーブルやクエリを印刷したときのページ設定が次に開くと戻ってしまう
ページのトップへ戻る